offlineimap-6.7.0.3.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # Normally you need only one version of this.
  5. DISTUTILS_SINGLE_IMPL=1
  6. PYTHON_COMPAT=( python2_7 )
  7. PYTHON_REQ_USE="threads,sqlite?,ssl?"
  8. inherit distutils-r1
  9. DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
  10. HOMEPAGE="http://offlineimap.org"
  11. SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  15. IUSE="doc ssl sqlite"
  16. DEPEND="doc? ( app-text/asciidoc )"
  17. # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
  18. PATCHES=(
  19. "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
  20. )
  21. src_compile() {
  22. distutils-r1_src_compile
  23. use doc && emake -C docs man
  24. }
  25. src_install() {
  26. distutils-r1_src_install
  27. dodoc offlineimap.conf offlineimap.conf.minimal
  28. use doc && doman docs/{offlineimap.1,offlineimapui.7}
  29. }
  30. pkg_postinst() {
  31. if [[ -z ${REPLACING_VERSIONS} ]]; then
  32. elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
  33. elog "Sample configurations are in /usr/share/doc/${PF}/"
  34. elog ""
  35. elog "If you connect via ssl/tls and don't use CA cert checking, it will"
  36. elog "display the server's cert fingerprint and require you to add it to the"
  37. elog "configuration file to be sure it connects to the same server every"
  38. elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
  39. elog "check SSL server certificate) in cases where you have no CA cert."
  40. echo
  41. if use sqlite ; then
  42. elog "The sqlite USE flag only enables a dependency on sqlite. To use"
  43. elog "the sqlite backend you need to enable it in your .offlineimaprc"
  44. fi
  45. fi
  46. }