postfix-logwatch-1.40.03.ebuild 905 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="A log analyzer for postfix"
  5. HOMEPAGE="http://logreporters.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. RDEPEND="dev-lang/perl"
  11. src_prepare() {
  12. # Replace the default config file location with ours.
  13. local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
  14. local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
  15. sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
  16. || die 'failed to update the default config location'
  17. }
  18. src_compile() {
  19. # The default make target just outputs instructions. We don't want
  20. # the user to see these, so we avoid the default emake.
  21. :
  22. }
  23. src_install() {
  24. dodoc Bugs Changes README ${PN}.conf-topn
  25. doman ${PN}.1
  26. dobin ${PN}
  27. insinto /etc
  28. doins ${PN}.conf
  29. }