qmailanalog-0.70-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils fixheadtails toolchain-funcs
  4. DESCRIPTION="collection of tools to help you analyze qmail's activity record"
  5. SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
  6. HOMEPAGE="http://cr.yp.to/qmailanalog.html"
  7. LICENSE="freedist public-domain" # public-domain for files/tai64nfrac.c
  8. SLOT="0"
  9. KEYWORDS="x86 sparc ~amd64"
  10. IUSE=""
  11. DEPEND="sys-apps/groff"
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}"/${PV}-errno.patch
  16. ht_fix_file auto_home.c.do default.do Makefile
  17. }
  18. src_compile() {
  19. echo "/var/qmail" > conf-home
  20. echo "$(tc-getCC) ${CFLAGS}" > conf-cc
  21. echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
  22. emake || die
  23. $(tc-getCC) ${CFLAGS} "${FILESDIR}"/tai64nfrac.c -o tai64nfrac || die
  24. }
  25. src_test() { :; }
  26. src_install() {
  27. doman matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
  28. dodoc MATCHUP ACCOUNTING BLURB
  29. insopts -o root -g qmail -m 755
  30. insinto /var/qmail/bin
  31. into /var/qmail
  32. dobin columnt ddist deferrals failures matchup recipients rhosts
  33. dobin rxdelay senders successes suids xqp xrecipient xsender
  34. dobin zddist zdeferrals zfailures zoverall zrecipients zrhosts
  35. dobin zrxdelay zsenders zsendmail zsuccesses zsuids tai64nfrac
  36. }