queue-fix-1.4-r2.ebuild 949 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs fixheadtails
  4. DESCRIPTION="Qmail Queue Repair Application with support for big-todo"
  5. HOMEPAGE="http://www.netmeridian.com/e-huss/"
  6. SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
  7. mirror://qmail/queue-fix-todo.patch"
  8. LICENSE="all-rights-reserved public-domain" # includes code from qmail
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
  11. RESTRICT="mirror bindist"
  12. PDEPEND="virtual/qmail"
  13. src_unpack() {
  14. unpack ${P}.tar.gz
  15. epatch "${DISTDIR}"/queue-fix-todo.patch
  16. sed -i 's/^extern int errno;/#include <errno.h>/' "${S}"/error.h
  17. ht_fix_file "${S}"/Makefile*
  18. }
  19. src_compile() {
  20. echo "$(tc-getCC) ${CFLAGS}" > conf-cc
  21. echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
  22. emake || die
  23. }
  24. src_install () {
  25. into /var/qmail
  26. dobin queue-fix || die
  27. into /usr
  28. dodoc README CHANGES
  29. }