vchkuser-0.4.ebuild 930 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit autotools qmail
  5. DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
  6. HOMEPAGE="https://github.com/hollow/vchkuser"
  7. SRC_URI="https://github.com/hollow/vchkuser/tarball/v${PV} -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug"
  12. DEPEND="net-mail/vpopmail
  13. || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
  14. RDEPEND=""
  15. S="${WORKDIR}/hollow-${PN}-8a048f7"
  16. src_prepare() {
  17. eautoreconf
  18. }
  19. src_configure() {
  20. econf \
  21. $(use_enable debug) \
  22. --with-vpopuser=vpopmail \
  23. --with-qmailgroup=nofiles \
  24. --with-vpopmaildir=/var/vpopmail \
  25. --with-qmaildir=${QMAIL_HOME}
  26. }
  27. src_install() {
  28. emake DESTDIR="${D}" install || die "emake failed"
  29. fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
  30. fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
  31. }