asterisk-rate_engine-0.5.4.ebuild 826 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. MY_PN="rate-engine"
  5. DESCRIPTION="Asterisk application for least-cost routing"
  6. HOMEPAGE="http://www.trollphone.org/files/"
  7. SRC_URI="http://www.trollphone.org/files/${MY_PN}-${PV}.tar.gz"
  8. IUSE=""
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~x86 ~amd64"
  12. DEPEND="dev-libs/libpcre
  13. virtual/mysql
  14. >=net-misc/asterisk-1.0.5-r1
  15. !>=net-misc/asterisk-1.1.0"
  16. S=${WORKDIR}/${MY_PN}-${PV}
  17. src_unpack() {
  18. unpack ${A}
  19. cd "${S}"
  20. # cflag fixes, install fixes and changes for asterisk-config
  21. epatch "${FILESDIR}"/${MY_PN}-${PV}-astcfg.diff
  22. }
  23. src_compile() {
  24. emake -j1 || die "emake failed"
  25. }
  26. src_install() {
  27. make DESTDIR="${D}" install samples || die
  28. dodoc ChangeLog DISCLAIMER NEWS README TODO *.sql *.conf*
  29. }