connect-1.103.ebuild 873 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. IUSE=""
  6. DESCRIPTION="network connection relaying command (proxy)"
  7. HOMEPAGE="https://bitbucket.org/gotoh/connect"
  8. HG_COMMIT_ID="ee1fbc21da4b" # bitbucket commit id
  9. #SRC_URI="https://www.bitbucket.org/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
  10. SRC_URI="https://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~ppc64 ~x86"
  14. DEPEND=""
  15. RDEPEND=""
  16. S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
  17. src_compile() {
  18. $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
  19. }
  20. src_install() {
  21. dobin ${PN}
  22. }
  23. pkg_postinst() {
  24. einfo
  25. einfo "There is no manpage."
  26. einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
  27. einfo
  28. }