dcetest-2.0.ebuild 742 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="dcetest is a clone of the Windows rpcinfo"
  4. HOMEPAGE="http://www.atstake.com/research/tools/info_gathering/"
  5. SRC_URI="http://www.atstake.com/research/tools/info_gathering/dcetest.tar"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="ppc x86"
  9. IUSE=""
  10. DEPEND="sys-apps/sed"
  11. RDEPEND=""
  12. S=${WORKDIR}/${PN}
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. # cleanup the makefile a little
  17. sed -e '/^CC/d' -i Makefile
  18. sed -e 's/CFLAGS.*/CFLAGS += -Wall -funsigned-char -fPIC/g' -i Makefile
  19. }
  20. src_compile() {
  21. emake || die
  22. }
  23. src_install() {
  24. dobin dcetest || die
  25. dodoc CHANGELOG README VERSION nt4sp6adefault.txt out out.txt out2.txt w2ksp0.txt
  26. }