dhcdrop-0.5.ebuild 639 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Effectively suppresses illegal DHCP servers on the LAN"
  6. HOMEPAGE="http://www.netpatch.ru/dhcdrop.html"
  7. SRC_URI="http://www.netpatch.ru/projects/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~mips ~x86"
  11. IUSE="static"
  12. RDEPEND="!static? ( net-libs/libpcap )"
  13. DEPEND="static? ( net-libs/libpcap[static-libs] )
  14. ${RDEPEND}"
  15. DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
  16. src_prepare() {
  17. epatch_user
  18. }
  19. src_configure() {
  20. econf $(use static && echo "--enable-static-build")
  21. }