dhcpcd-ui-0.7.4.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils systemd
  5. DESCRIPTION="Desktop notification and configuration for dhcpcd"
  6. HOMEPAGE="http://roy.marples.name/projects/dhcpcd-ui/"
  7. SRC_URI="http://roy.marples.name/downloads/${PN%-ui}/${P}.tar.bz2"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug gtk gtk3 qt4 libnotify"
  12. REQUIRED_USE="?? ( gtk gtk3 qt4 )
  13. gtk3? ( !gtk ) gtk? ( !gtk3 )"
  14. DEPEND="${DEPEND}
  15. virtual/libintl
  16. libnotify? (
  17. gtk? ( x11-libs/libnotify )
  18. gtk3? ( x11-libs/libnotify )
  19. qt4? ( kde-frameworks/kdelibs:4 )
  20. )
  21. gtk? ( x11-libs/gtk+:2 )
  22. gtk3? ( x11-libs/gtk+:3 )
  23. qt4? ( dev-qt/qtgui:4 )"
  24. RDEPEND=">=net-misc/dhcpcd-6.4.4"
  25. src_prepare()
  26. {
  27. epatch_user
  28. }
  29. src_configure()
  30. {
  31. local myeconfargs=(
  32. $(use_enable debug)
  33. $(usex gtk '--with-gtk=gtk+-2.0 --with-icons' '')
  34. $(usex gtk3 '--with-gtk=gtk+-3.0 --with-icons' '')
  35. $(usex qt4 '--with-qt --with-icons' '--without-qt')
  36. $(use_enable libnotify notification)
  37. $(use gtk || use gtk3 || echo '--without-gtk')
  38. $(use gtk || use gtk3 || use qt4 || echo '--without-icons')
  39. )
  40. econf "${myeconfargs[@]}"
  41. }
  42. src_install()
  43. {
  44. emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
  45. systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
  46. }