dhcpcd-ui-0.7.5.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils qmake-utils systemd
  5. DESCRIPTION="Desktop notification and configuration for dhcpcd"
  6. HOMEPAGE="http://roy.marples.name/projects/dhcpcd-ui/"
  7. SRC_URI="http://roy.marples.name/downloads/${PN%-ui}/${P}.tar.bz2"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug gtk gtk3 qt4 libnotify"
  12. REQUIRED_USE="
  13. ?? ( gtk gtk3 qt4 )
  14. gtk3? ( !gtk )
  15. gtk? ( !gtk3 )"
  16. DEPEND="${DEPEND}
  17. virtual/libintl
  18. libnotify? (
  19. gtk? ( x11-libs/libnotify )
  20. gtk3? ( x11-libs/libnotify )
  21. qt4? ( kde-frameworks/kdelibs:4 )
  22. )
  23. gtk? ( x11-libs/gtk+:2 )
  24. gtk3? ( x11-libs/gtk+:3 )
  25. qt4? ( dev-qt/qtgui:4 )"
  26. RDEPEND=">=net-misc/dhcpcd-6.4.4"
  27. pkg_setup() {
  28. if use qt4 ; then
  29. # This is required in case a user still has qt3 installed
  30. export QTDIR="$(qt4_get_bindir)"
  31. fi
  32. }
  33. src_configure() {
  34. local myeconfargs=(
  35. $(use_enable debug)
  36. $(usex gtk '--with-gtk=gtk+-2.0 --with-icons' '')
  37. $(usex gtk3 '--with-gtk=gtk+-3.0 --with-icons' '')
  38. $(usex qt4 '--with-qt --with-icons' '--without-qt')
  39. $(use_enable libnotify notification)
  40. $(use gtk || use gtk3 || echo '--without-gtk')
  41. $(use gtk || use gtk3 || use qt4 || echo '--without-icons')
  42. )
  43. econf "${myeconfargs[@]}"
  44. }
  45. src_install() {
  46. emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
  47. systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
  48. }