dibbler-1.0.1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils readme.gentoo systemd
  5. DESCRIPTION="Portable DHCPv6 implementation (server, client and relay)"
  6. HOMEPAGE="http://klub.com.pl/dhcpv6/"
  7. SRC_URI="http://klub.com.pl/dhcpv6/dibbler/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ~mips x86"
  11. IUSE="doc"
  12. DEPEND="doc? ( || (
  13. dev-texlive/texlive-latexextra
  14. dev-tex/floatflt )
  15. )"
  16. RDEPEND=""
  17. DOC_CONTENTS="Make sure that you modify client.conf, server.conf and/or relay.conf
  18. to suit your needs. They are stored in /etc/dibbler"
  19. src_prepare() {
  20. epatch_user
  21. }
  22. src_compile() {
  23. emake
  24. # devel documentation is broken and users should consult the online version
  25. # http://klub.com.pl/dhcpv6/doxygen/
  26. use doc && emake -C doc/ user
  27. }
  28. src_install() {
  29. readme.gentoo_create_doc
  30. dosbin dibbler-{client,relay,server}
  31. doman doc/man/*.8
  32. insinto /etc/dibbler
  33. doins doc/examples/*.conf
  34. dodir /var/lib/dibbler
  35. dodoc AUTHORS CHANGELOG RELNOTES TODO
  36. use doc && dodoc doc/dibbler-user.pdf
  37. doinitd "${FILESDIR}"/dibbler-{client,relay,server}
  38. systemd_dounit "${FILESDIR}"/dibbler-client.service
  39. }