directvnc-0.7.6-r1.ebuild 907 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. AUTOTOOLS_AUTORECONF=1
  6. inherit eutils autotools-utils
  7. DESCRIPTION="Very thin VNC client for unix framebuffer systems"
  8. HOMEPAGE="https://drinkmilk.github.com/directvnc/"
  9. SRC_URI="https://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~x86 ~ppc ~amd64"
  13. IUSE="+mouse dmalloc"
  14. RDEPEND="dev-libs/DirectFB[fbcon,dynload]
  15. virtual/jpeg"
  16. DEPEND="${RDEPEND}
  17. dmalloc? ( dev-libs/dmalloc )
  18. x11-proto/xproto"
  19. DOCS=( NEWS THANKS )
  20. src_prepare() {
  21. # Make mouse support optional
  22. use mouse || epatch "${FILESDIR}/${P}-mouse.patch"
  23. sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
  24. autotools-utils_src_prepare
  25. }
  26. src_configure() {
  27. myeconfargs=(
  28. $(use_with dmalloc)
  29. )
  30. autotools-utils_src_configure
  31. }