dleyna-server-0.5.0.ebuild 868 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="library for implementing services that allow clients to discover, browse and manipulate DLNA Servers"
  6. HOMEPAGE="https://01.org/dleyna/"
  7. SRC_URI="https://01.org/sites/default/files/downloads/dleyna/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64"
  11. IUSE=""
  12. RDEPEND="
  13. >=dev-libs/glib-2.28:2
  14. dev-libs/libxml2
  15. >=media-libs/gupnp-dlna-0.9.4:2.0
  16. >=net-libs/dleyna-core-0.5
  17. >=net-libs/gssdp-0.13.2
  18. >=net-libs/gupnp-0.20.3
  19. >=net-libs/gupnp-av-0.11.5
  20. >=net-libs/libsoup-2.28.2:2.4
  21. "
  22. DEPEND="${RDEPEND}
  23. virtual/pkgconfig
  24. "
  25. src_prepare() {
  26. # Fix build with recent gupnp, bug #597952
  27. epatch "${FILESDIR}"/${P}-fix-references-to-GUPnPContextManager.patch
  28. default
  29. }
  30. src_install() {
  31. default
  32. prune_libtool_files
  33. }