dropbox-cli-1-r1.ebuild 557 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-r1
  6. DESCRIPTION="Cli interface for dropbox daemon (python)"
  7. HOMEPAGE="http://www.dropbox.com/"
  8. SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="net-misc/dropbox
  15. ${PYTHON_DEPS}"
  16. S=${WORKDIR}
  17. src_install() {
  18. newbin ${P}.py ${PN}
  19. python_replicate_script "${D}"/usr/bin/${PN}
  20. }