fatrat-1.2.0_beta2_p20150803.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. SNAPSHOT="b5be2b17ee291f6253484ec749037bc2c9200ccc"
  5. inherit cmake-utils
  6. DESCRIPTION="Qt4-based download/upload manager"
  7. HOMEPAGE="http://fatrat.dolezel.info/"
  8. if [[ -n "${SNAPSHOT}" ]] ; then
  9. SRC_URI="https://github.com/LubosD/fatrat/tarball/${SNAPSHOT} -> ${P}.tar.gz"
  10. S="${WORKDIR}/LubosD-${PN}-${SNAPSHOT:0:7}"
  11. else
  12. SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.xz"
  13. fi
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~x86"
  17. IUSE="bittorrent +curl doc xmpp nls webinterface"
  18. RDEPEND="dev-qt/qtdbus:4
  19. dev-qt/qtgui:4
  20. dev-qt/qtsvg:4
  21. bittorrent? (
  22. >=net-libs/libtorrent-rasterbar-0.14.5
  23. >=dev-cpp/asio-1.1.0
  24. dev-qt/qtwebkit:4
  25. )
  26. curl? ( >=net-misc/curl-7.18.2 )
  27. doc? ( dev-qt/qthelp:4 )
  28. xmpp? ( net-libs/gloox )
  29. webinterface? ( dev-qt/qtscript:4 )"
  30. DEPEND="${RDEPEND}
  31. virtual/pkgconfig
  32. nls? ( sys-devel/gettext )"
  33. PATCHES=(
  34. "${FILESDIR}/${P}-build.patch"
  35. )
  36. src_configure() {
  37. local mycmakeargs=(
  38. -DWITH_BITTORRENT="$(usex bittorrent ON OFF)"
  39. -DWITH_CURL="$(usex curl ON OFF)"
  40. -DWITH_DOCUMENTATION="$(usex doc ON OFF)"
  41. -DWITH_JABBER="$(usex xmpp ON OFF)"
  42. -DWITH_NLS="$(usex nls ON OFF)"
  43. -DWITH_WEBINTERFACE="$(usex webinterface ON OFF)"
  44. )
  45. cmake-utils_src_configure
  46. }
  47. pkg_postinst() {
  48. # this is a completely optional and NOT automagic dep
  49. if ! has_version dev-libs/geoip; then
  50. elog "If you want GeoIP support, emerge dev-libs/geoip."
  51. fi
  52. }