geoipupdate-2.3.1.ebuild 574 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="performs automatic updates of GeoIP2 and GeoIP Legacy binary databases"
  5. HOMEPAGE="https://github.com/maxmind/geoipupdate"
  6. SRC_URI="https://github.com/maxmind/${PN}/releases/download/v${PV}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~s390 sparc x86 ~x86-fbsd"
  10. DEPEND="
  11. net-misc/curl
  12. sys-libs/zlib
  13. "
  14. RDEPEND="
  15. ${DEPEND}
  16. !<dev-libs/geoip-1.6.0
  17. "
  18. src_install() {
  19. default
  20. keepdir /usr/share/GeoIP
  21. }