gns3-server-1.5.2-r1.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit distutils-r1 eutils
  6. DESCRIPTION="GNS3 server to asynchronously manage emulators"
  7. HOMEPAGE="http://www.gns3.net/"
  8. SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. RDEPEND=">=app-emulation/dynamips-0.2.12
  13. =dev-python/aiohttp-0.21.5[${PYTHON_USEDEP}]
  14. >=dev-python/docker-py-1.4.0[${PYTHON_USEDEP}]
  15. >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
  16. >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
  17. >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
  18. >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
  19. >=dev-python/raven-5.2.0[${PYTHON_USEDEP}]
  20. >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
  21. >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
  22. >=dev-python/python-zipstream-1.1.4[${PYTHON_USEDEP}]
  23. >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]"
  24. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  25. pkg_postinst() {
  26. ewarn "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
  27. ewarn ""
  28. ewarn "The following is a list of packages that can be added:"
  29. ewarn "app-emulation/qemu, app-emulation/virtualbox, and net-analyzer/wireshark"
  30. ewarn ""
  31. ewarn "The following packages are currently unsupported:"
  32. ewarn "iouyap and vpcs"
  33. }