gns3-server-1.5.3.1.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit distutils-r1 eutils
  6. DESCRIPTION="GNS3 server to asynchronously manage emulators"
  7. HOMEPAGE="http://www.gns3.net/"
  8. SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. RESTRICT="test"
  13. RDEPEND=">=app-emulation/dynamips-0.2.12
  14. >=dev-python/aiohttp-1.2.0[${PYTHON_USEDEP}]
  15. >=dev-python/aiohttp-cors-0.5.0[${PYTHON_USEDEP}]
  16. >=dev-python/docker-py-1.4.0[${PYTHON_USEDEP}]
  17. >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
  18. >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
  19. >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
  20. >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
  21. >=dev-python/raven-5.2.0[${PYTHON_USEDEP}]
  22. >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
  23. >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
  24. >=dev-python/python-zipstream-1.1.4[${PYTHON_USEDEP}]
  25. >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]
  26. >=dev-python/typing-3.5.3.0[${PYTHON_USEDEP}]
  27. >=dev-python/yarl-0.7.0[${PYTHON_USEDEP}]"
  28. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  29. pkg_postinst() {
  30. ewarn "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
  31. ewarn ""
  32. ewarn "The following is a list of packages that can be added:"
  33. ewarn "app-emulation/qemu, app-emulation/virtualbox"
  34. ewarn "app-emulation/docker and net-analyzer/wireshark"
  35. ewarn ""
  36. ewarn "The following packages are currently unsupported:"
  37. ewarn "iouyap and vpcs"
  38. }