gsasl-1.8.0-r1.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit autotools eutils
  5. DESCRIPTION="The GNU SASL client, server, and library"
  6. HOMEPAGE="https://www.gnu.org/software/gsasl/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
  11. IUSE="doc gcrypt idn kerberos nls ntlm static-libs +threads"
  12. DEPEND="
  13. gcrypt? ( dev-libs/libgcrypt:0 )
  14. idn? ( net-dns/libidn )
  15. kerberos? ( virtual/krb5 )
  16. nls? ( >=sys-devel/gettext-0.18.1 )
  17. ntlm? ( net-libs/libntlm )
  18. "
  19. RDEPEND="${DEPEND}"
  20. src_prepare() {
  21. epatch "${FILESDIR}/${PN}-gss-extra.patch"
  22. sed -i -e '/gl_WARN_ADD(\[-Werror/d' \
  23. -e 's/ -Werror//' configure.ac || die
  24. sed -i -e 's/ -Werror//' lib/configure.ac || die
  25. eautoreconf
  26. }
  27. src_configure() {
  28. local krb5_impl
  29. if use kerberos; then
  30. krb5_impl="--with-gssapi-impl="
  31. krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
  32. fi
  33. econf \
  34. --enable-client \
  35. --enable-server \
  36. --disable-valgrind-tests \
  37. --disable-rpath \
  38. --without-libshishi \
  39. --without-libgss \
  40. --disable-kerberos_v5 \
  41. $(use_enable kerberos gssapi) \
  42. ${krb5_impl} \
  43. $(use_enable kerberos gs2) \
  44. $(use_with gcrypt libgcrypt) \
  45. $(use_enable nls) \
  46. $(use_with idn stringprep) \
  47. $(use_enable ntlm) \
  48. $(use_with ntlm libntlm) \
  49. $(use_enable static-libs static) \
  50. $(use_enable threads)
  51. }
  52. src_install() {
  53. default
  54. if ! use static-libs; then
  55. rm -f "${D}"/usr/lib*/lib*.la
  56. fi
  57. doman doc/gsasl.1 doc/man/*.3
  58. if use doc; then
  59. dodoc doc/*.{eps,ps,pdf}
  60. dohtml doc/*.html
  61. docinto examples
  62. dodoc examples/*.c
  63. fi
  64. }