gsutil-4.20.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="command line tool for interacting with cloud storage services"
  7. HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
  8. SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~x86"
  12. IUSE=""
  13. # The oauth2client-2 dep sucks.
  14. # https://github.com/GoogleCloudPlatform/gsutil/issues/355
  15. RDEPEND="${PYTHON_DEPS}
  16. >=dev-python/boto-2.39.0[${PYTHON_USEDEP}]
  17. >=dev-python/crcmod-1.7[${PYTHON_USEDEP}]
  18. >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
  19. >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
  20. >=dev-python/gcs-oauth2-boto-plugin-1.14[${PYTHON_USEDEP}]
  21. >=dev-python/google-apitools-0.5.3[${PYTHON_USEDEP}]
  22. >=dev-python/oauth2client-2.2.0[${PYTHON_USEDEP}]
  23. >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
  24. >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
  25. >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
  26. >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"
  27. DEPEND="${RDEPEND}
  28. dev-python/setuptools[${PYTHON_USEDEP}]"
  29. S=${WORKDIR}/${PN}
  30. DOCS=( README.md CHANGES.md )
  31. PATCHES=(
  32. "${FILESDIR}"/${PN}-4.20-use-friendy-version-checks.patch
  33. )
  34. python_prepare_all() {
  35. distutils-r1_python_prepare_all
  36. sed -i \
  37. -e '/SocksiPy-branch/d' \
  38. setup.py || die
  39. }
  40. python_test() {
  41. export BOTO_CONFIG=${FILESDIR}/dummy.boto
  42. ${PYTHON} gslib/__main__.py test -u || die "tests failed"
  43. }