hashcash-1.22-r1.ebuild 680 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. IUSE=""
  5. DESCRIPTION="Utility to generate hashcash tokens"
  6. HOMEPAGE="http://www.hashcash.org"
  7. SRC_URI="http://www.hashcash.org/source/${P}.tgz"
  8. LICENSE="CPL-1.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc x86"
  11. src_unpack() {
  12. unpack ${A}
  13. cd "${S}"
  14. sed -i -e "/COPT_GENERIC = -O3/d" Makefile || die
  15. }
  16. src_compile() {
  17. emake CC="$(tc-getCC)" generic || die
  18. }
  19. src_install() {
  20. dobin hashcash
  21. doman hashcash.1
  22. dodoc CHANGELOG
  23. insinto /usr/share/doc/${PF}/examples
  24. doins contrib/hashcash-{request,sendmail{,.txt}} \
  25. contrib/hashfork.{c,py,txt}
  26. }