igmpproxy-0.1-r2.ebuild 634 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit linux-info systemd
  5. DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
  6. HOMEPAGE="https://sourceforge.net/projects/igmpproxy"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2 Stanford"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
  13. src_install() {
  14. emake DESTDIR="${D}" install
  15. newinitd "${FILESDIR}/${PN}-init.d" ${PN}
  16. newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
  17. systemd_dounit "${FILESDIR}/${PN}.service"
  18. }