ipsc-0.4.3.2-r2.ebuild 732 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="IP Subnet Calculator"
  5. HOMEPAGE="http://packages.debian.org/unstable/net/ipsc"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. RDEPEND=""
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. sed -i \
  16. -e "s:^CC = gcc:CC = $(tc-getCC):" \
  17. -e "/^CFLAGS = .*/d" \
  18. -e "s/^LIBS = /LDLIBS = /" \
  19. -e '/$(CC).*\\$/,+1d' \
  20. -e '/$(CC)/d' \
  21. src/Makefile || die "Unable to sed upstream Makefile"
  22. }
  23. src_compile() {
  24. cd src
  25. emake || die "Compilation failed"
  26. }
  27. src_install() {
  28. dodoc README ChangeLog TODO CONTRIBUTORS
  29. dobin src/ipsc
  30. doman src/ipsc.1
  31. }