jumpgate-0.7.ebuild 576 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils toolchain-funcs
  5. DESCRIPTION="An advanced TCP connection forwarder"
  6. HOMEPAGE="http://jumpgate.sourceforge.net/"
  7. SRC_URI="http://jumpgate.sourceforge.net/${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="x86 amd64"
  11. IUSE=""
  12. src_prepare() {
  13. if [ "$(gcc-major-version)" == "4" ] ; then
  14. sed -i -e '/^AC_CHECK_TYPE/d' configure.in || die
  15. eautoreconf
  16. fi
  17. }
  18. src_install() {
  19. emake install install_prefix="${D}"
  20. dodoc README ChangeLog
  21. }