libteam-1.22.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. inherit autotools-utils linux-info
  6. DESCRIPTION="Library and tools set for controlling team network device"
  7. HOMEPAGE="http://libteam.org"
  8. SRC_URI="http://libteam.org/files/${P}.tar.gz"
  9. LICENSE="LGPL-2.1+"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
  12. IUSE="dbus debug examples static-libs +syslog zmq"
  13. DEPEND=">=dev-libs/jansson-2.4
  14. dev-libs/libdaemon
  15. >=dev-libs/libnl-3.2.19[utils]
  16. dbus? ( sys-apps/dbus )
  17. zmq? ( >=net-libs/zeromq-3.2.0 )
  18. "
  19. RDEPEND="${DEPEND}
  20. syslog? ( virtual/logger )"
  21. CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP ~NET_TEAM_MODE_BROADCAST ~NET_TEAM_MODE_RANDOM ~NET_TEAM_MODE_LOADBALANCE"
  22. ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
  23. Only >=3.3.0 kernel version support in team mode"
  24. DOCS=( README )
  25. src_configure() {
  26. local myeconfargs=(
  27. $(use_enable debug)
  28. $(use_enable syslog logging)
  29. $(use_enable dbus)
  30. $(use_enable zmq)
  31. )
  32. autotools-utils_src_configure
  33. }
  34. src_install() {
  35. autotools-utils_src_install
  36. insinto /etc/dbus-1/system.d
  37. doins teamd/dbus/teamd.conf
  38. if use examples; then
  39. docinto examples
  40. dodoc teamd/example_configs/*
  41. fi
  42. }