lksctp-tools-1.0.16.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib flag-o-matic autotools autotools-utils linux-info
  5. DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
  6. HOMEPAGE="http://lksctp.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/lksctp/${P}.tar.gz"
  8. LICENSE="|| ( GPL-2+ LGPL-2.1 )"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
  11. IUSE="kernel_linux static-libs"
  12. # This is only supposed to work with Linux to begin with.
  13. DEPEND=">=sys-kernel/linux-headers-2.6"
  14. RDEPEND=""
  15. REQUIRED_USE="kernel_linux"
  16. CONFIG_CHECK="~IP_SCTP"
  17. WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${PN}-1.0.8-prefix.patch #181602
  20. eautoreconf
  21. }
  22. src_configure() {
  23. append-flags -fno-strict-aliasing
  24. autotools-utils_src_configure
  25. }
  26. DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )
  27. src_install() {
  28. autotools-utils_src_install
  29. dodoc doc/*txt
  30. newdoc src/withsctp/README README.withsctp
  31. # Don't install static library or libtool file, since this is used
  32. # only as preloadable library.
  33. use static-libs && rm "${D}"/usr/$(get_libdir)/${PN}/*.a
  34. }