megatools-1.9.98.ebuild 974 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. AUTOTOOLS_IN_SOURCE_BUILD=1
  6. inherit autotools-utils
  7. DESCRIPTION="Command line tools and C library for accessing Mega cloud storage"
  8. HOMEPAGE="https://github.com/megous/megatools"
  9. SRC_URI="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~arm ~x86"
  13. IUSE="fuse introspection static-libs"
  14. COMMON_DEPEND="dev-libs/glib:2
  15. dev-libs/openssl:0
  16. net-misc/curl
  17. fuse? ( sys-fs/fuse )
  18. "
  19. RDEPEND="${COMMON_DEPEND}
  20. net-libs/glib-networking[ssl]
  21. "
  22. DEPEND="${COMMON_DEPEND}
  23. virtual/pkgconfig
  24. app-text/asciidoc"
  25. src_configure() {
  26. local myeconfargs=(
  27. --enable-shared
  28. --enable-docs-build
  29. --disable-maintainer-mode
  30. --disable-warnings
  31. --disable-glibtest
  32. $(use_enable static-libs static)
  33. $(use_enable introspection)
  34. $(use_with fuse)
  35. )
  36. autotools-utils_src_configure
  37. }