monmotha-2.3.8-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="MonMotha IPTables-based firewall script"
  5. HOMEPAGE="http://monmotha.mplug.org/firewall/"
  6. LICENSE="GPL-2"
  7. KEYWORDS="x86 ~amd64"
  8. IUSE=""
  9. SLOT="0"
  10. RDEPEND=">=net-firewall/iptables-1.2.5"
  11. MY_PVP=(${PV//[-\._]/ })
  12. S=${WORKDIR}
  13. SRC_URI="http://monmotha.mplug.org/~monmotha/firewall/firewall/${MY_PVP[0]}.${MY_PVP[1]}/rc.firewall-${PV}"
  14. src_unpack() {
  15. cp "${DISTDIR}"/${A} "${S}"/
  16. }
  17. src_install() {
  18. newinitd "${FILESDIR}/monmotha.rc6" monmotha
  19. exeinto /etc/monmotha
  20. newexe "${S}/rc.firewall-${PV}" monmotha
  21. }
  22. pkg_postinst () {
  23. einfo "Don't forget to add the 'monmotha' startup script to your default"
  24. einfo "runlevel by typing the following command:"
  25. einfo ""
  26. einfo " rc-update add monmotha default"
  27. einfo ""
  28. einfo "You need to edit /etc/monmotha/monmotha before using"
  29. einfo "it. Enter the right vars in the file, start the script"
  30. einfo "by typing: '/etc/init.d/monmotha start' and it should work."
  31. einfo ""
  32. einfo "Don't forget to change the path to iptables!!!"
  33. einfo ""
  34. einfo "Note: If You are stopping the firewall, all iptables rulesets"
  35. einfo "will be flushed!!!"
  36. einfo ""
  37. }