mrouted-3.9.5-r1.ebuild 841 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit toolchain-funcs
  5. DESCRIPTION="IP multicast routing daemon"
  6. HOMEPAGE="http://troglobit.com/mrouted.shtml"
  7. SRC_URI="ftp://ftp.vmlinux.org/pub/People/jocke/${PN}/${P}.tar.bz2"
  8. LICENSE="Stanford GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="|| ( dev-util/yacc sys-devel/bison )"
  13. RDEPEND=""
  14. src_prepare() {
  15. # Respect user CFLAGS, remove upstream optimisation and -Werror
  16. sed -i Makefile \
  17. -e '/^CFLAGS/{s|[[:space:]]=| +=|g;s|-O2||g;s|-Werror||g}' \
  18. || die
  19. default
  20. }
  21. src_compile() {
  22. emake CC=$(tc-getCC)
  23. }
  24. src_install() {
  25. dobin mrouted
  26. dosbin mtrace mrinfo map-mbone
  27. doman mrouted.8 mtrace.8 mrinfo.8 map-mbone.8
  28. insinto /etc
  29. doins mrouted.conf
  30. newinitd "${FILESDIR}"/mrouted.rc mrouted
  31. }