mulk-0.6.0.ebuild 808 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit base
  5. MY_PV=${PV/_beta/}
  6. MY_P="${PN}-${MY_PV}"
  7. DESCRIPTION="Download agent similar to wget/curl"
  8. HOMEPAGE="http://mulk.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="checksum debug metalink"
  14. DEPEND="net-misc/curl
  15. app-text/htmltidy
  16. dev-libs/uriparser
  17. metalink? (
  18. media-libs/libmetalink
  19. checksum? ( dev-libs/openssl )
  20. )"
  21. REQUIRED_USE="checksum? ( metalink )"
  22. RDEPEND="${DEPEND}"
  23. S="${WORKDIR}/${MY_P}"
  24. PATCHES=(
  25. "${FILESDIR}"/${P}-large-file.patch
  26. )
  27. src_configure() {
  28. econf \
  29. $(use_enable debug) \
  30. $(use_enable metalink) \
  31. $(use metalink && use checksum && echo --enable-checksum)
  32. }