mulk-0.7.0.ebuild 758 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit base
  5. MY_PV=${PV/_beta/}
  6. MY_P="${PN}-${MY_PV}"
  7. DESCRIPTION="Download agent similar to wget/curl"
  8. HOMEPAGE="http://mulk.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="checksum debug metalink"
  14. DEPEND="net-misc/curl
  15. app-text/htmltidy
  16. dev-libs/uriparser
  17. metalink? (
  18. media-libs/libmetalink
  19. checksum? ( dev-libs/openssl )
  20. )"
  21. REQUIRED_USE="checksum? ( metalink )"
  22. RDEPEND="${DEPEND}"
  23. S="${WORKDIR}/${MY_P}"
  24. src_configure() {
  25. econf \
  26. $(use_enable debug) \
  27. $(use_enable metalink) \
  28. $(use metalink && use checksum && echo --enable-checksum)
  29. }