netkit-bootparamd-0.17-r2.ebuild 980 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2007 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="Netkit - bootparamd"
  5. HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
  6. SRC_URI="mirror://debian/pool/main/n/netkit-bootparamd/${PN}_${PV}.orig.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~hppa ~mips ppc sparc x86"
  10. IUSE=""
  11. DEPEND="!<=net-misc/netkit-bootpd-0.17-r2"
  12. RDEPEND=${DEPEND}
  13. src_unpack() {
  14. unpack ${A}
  15. epatch "${FILESDIR}"/0.17-jumpstart.patch
  16. }
  17. src_compile() {
  18. # Note this is not an autoconf configure
  19. ./configure || die "configure failed"
  20. emake || die "make failed"
  21. }
  22. src_install() {
  23. into /usr
  24. dosbin rpc.bootparamd/bootparamd || die "installing binary failed"
  25. dosym bootparamd /usr/sbin/rpc.bootparamd
  26. doman rpc.bootparamd/bootparamd.8
  27. dosym bootparamd.8.gz /usr/share/man/man8/rpc.bootparamd.8.gz
  28. doman rpc.bootparamd/bootparams.5
  29. dodoc README ChangeLog
  30. newdoc rpc.bootparamd/README README.bootparamd
  31. }