netkit-timed-0.17-r10.ebuild 1020 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit flag-o-matic toolchain-funcs
  5. IUSE=""
  6. DESCRIPTION="Netkit - timed"
  7. SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
  8. HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
  9. KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
  10. LICENSE="BSD GPL-2"
  11. SLOT="0"
  12. DEPEND=""
  13. RDEPEND=""
  14. src_prepare() {
  15. eapply "${FILESDIR}"/0.17-CFLAG-DEF-fix.patch
  16. eapply "${FILESDIR}"/0.17-timed-opt-parsing.patch
  17. sed -i configure \
  18. -e '/^LDFLAGS=/d' \
  19. || die "sed configure"
  20. default
  21. }
  22. src_configure() {
  23. # Note this is not an autoconf configure script. econf fails
  24. append-flags -DCLK_TCK=CLOCKS_PER_SEC
  25. ./configure --prefix=/usr --with-c-compiler=$(tc-getCC) || die "bad configure"
  26. }
  27. src_install() {
  28. dosbin timed/timed/timed
  29. doman timed/timed/timed.8
  30. dosbin timed/timedc/timedc
  31. doman timed/timedc/timedc.8
  32. dodoc README ChangeLog BUGS
  33. newinitd "${FILESDIR}"/timed.rc6 timed
  34. }