networkmanager-fortisslvpn-1.2.2.ebuild 980 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
  5. inherit gnome2 autotools
  6. DESCRIPTION="NetworkManager Fortinet SSLVPN compatible plugin"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="gtk"
  12. RDEPEND="
  13. >=net-misc/networkmanager-1.1:=
  14. >=dev-libs/glib-2.32:2
  15. net-dialup/ppp:=
  16. >=net-vpn/openfortivpn-1.2.0
  17. gtk? (
  18. >=app-crypt/libsecret-0.18
  19. >=gnome-extra/nm-applet-1.2.0
  20. >=x11-libs/gtk+-3.4:3
  21. )
  22. "
  23. DEPEND="${RDEPEND}
  24. sys-devel/gettext
  25. >=dev-util/intltool-0.35
  26. virtual/pkgconfig
  27. "
  28. src_prepare() {
  29. # Upstream patch 377ba9ca7fb33f3fb2ba5258a5af666869947597
  30. eapply "${FILESDIR}/${P}-location-fix.diff"
  31. eapply_user
  32. eautoreconf
  33. gnome2_src_prepare
  34. }
  35. src_configure() {
  36. gnome2_src_configure \
  37. --disable-static \
  38. --with-dist-version=Gentoo \
  39. --localstatedir=/var \
  40. $(use_with gtk gnome)
  41. }