networkmanager-pptp-1.2.4.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
  5. inherit gnome2
  6. DESCRIPTION="NetworkManager PPTP plugin"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE="gtk"
  12. RDEPEND="
  13. >=net-misc/networkmanager-1.2.0:=
  14. >=dev-libs/dbus-glib-0.74
  15. >=dev-libs/glib-2.32:2
  16. net-dialup/ppp:=
  17. net-dialup/pptpclient
  18. gtk? (
  19. >=app-crypt/libsecret-0.18
  20. >=gnome-extra/nm-applet-1.2.0
  21. >=x11-libs/gtk+-3.4:3
  22. )
  23. "
  24. DEPEND="${RDEPEND}
  25. sys-devel/gettext
  26. dev-util/intltool
  27. virtual/pkgconfig
  28. "
  29. src_configure() {
  30. local myconf
  31. # Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
  32. local PPPD_VER=`best_version net-dialup/ppp`
  33. PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
  34. PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
  35. myconf="${myconf} --with-pppd-plugin-dir=/usr/$(get_libdir)/pppd/${PPPD_VER}"
  36. gnome2_src_configure \
  37. --disable-more-warnings \
  38. --disable-static \
  39. --with-dist-version=Gentoo \
  40. $(use_with gtk gnome) \
  41. ${myconf}
  42. }