networkmanager-vpnc-1.2.4.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
  5. inherit gnome2
  6. DESCRIPTION="NetworkManager VPNC plugin"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE="gtk test"
  12. RDEPEND="
  13. >=net-misc/networkmanager-1.2.0:=
  14. >=dev-libs/dbus-glib-0.74
  15. >=dev-libs/glib-2.32:2
  16. >=net-vpn/vpnc-0.5.3_p550
  17. gtk? (
  18. >=app-crypt/libsecret-0.18
  19. >=gnome-extra/nm-applet-1.2.0
  20. >=x11-libs/gtk+-3.4:3
  21. )
  22. "
  23. DEPEND="${RDEPEND}
  24. sys-devel/gettext
  25. dev-util/intltool
  26. virtual/pkgconfig
  27. "
  28. src_prepare() {
  29. # Test will fail if the machine doesn't have a particular locale installed
  30. # https://bugzilla.gnome.org/show_bug.cgi?id=742708
  31. sed '/test_non_utf8_import (plugin/ d' \
  32. -i properties/tests/test-import-export.c || die "sed failed"
  33. gnome2_src_prepare
  34. }
  35. src_configure() {
  36. gnome2_src_configure \
  37. --disable-more-warnings \
  38. --disable-static \
  39. --with-dist-version=Gentoo \
  40. $(use_with gtk gnome)
  41. }