ofono-1.16.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib systemd
  5. DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
  6. HOMEPAGE="http://ofono.org/"
  7. SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
  11. IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev"
  12. REQUIRED_USE="dundee? ( bluetooth )"
  13. RDEPEND=">=sys-apps/dbus-1.4
  14. >=dev-libs/glib-2.28
  15. net-misc/mobile-broadband-provider-info
  16. bluetooth? ( >=net-wireless/bluez-4.99 )
  17. udev? ( virtual/udev )
  18. examples? ( dev-python/dbus-python )
  19. tools? ( virtual/libusb:1 )"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. DOCS=( ChangeLog AUTHORS )
  23. src_configure() {
  24. econf \
  25. $(use_enable threads) \
  26. $(use_enable udev) \
  27. $(use_enable isimodem) \
  28. $(use_enable atmodem) \
  29. $(use_enable cdmamodem) \
  30. $(use_enable datafiles) \
  31. $(use_enable dundee) \
  32. $(use_enable bluetooth) \
  33. $(use_enable phonesim) \
  34. $(use_enable provision) \
  35. $(use_enable qmimodem) \
  36. $(use_enable tools) \
  37. $(use_enable examples test) \
  38. --disable-maintainer-mode \
  39. --localstatedir=/var \
  40. --with-systemdunitdir="$(systemd_get_unitdir)"
  41. }
  42. src_install() {
  43. default
  44. if use tools ; then
  45. dobin tools/auto-enable \
  46. tools/huawei-audio \
  47. tools/lookup-provider-name \
  48. tools/lookup-apn \
  49. tools/get-location \
  50. tools/qmi \
  51. tools/tty-redirector
  52. fi
  53. newinitd "${FILESDIR}"/${PN}.initd ${PN}
  54. use doc && dodoc doc/*.txt
  55. }