openssh-blacklist-0.4.1.ebuild 919 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="Source files of vuln Debian keys"
  5. HOMEPAGE="http://packages.qa.debian.org/o/openssh-blacklist.html"
  6. SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="amd64 hppa x86"
  10. IUSE=""
  11. DEPEND=""
  12. maint_pkg_create() {
  13. wget http://cvsweb.openwall.com/cgi/cvsweb.cgi/~checkout~/Owl/packages/openssh/blacklist-encode.c -O "${FILESDIR}"/blacklist-encode.c
  14. }
  15. src_unpack() {
  16. unpack ${A}
  17. cd "${S}"
  18. cp "${FILESDIR}"/blacklist-encode.c . || die
  19. }
  20. src_compile() {
  21. emake \
  22. CC="$(tc-getBUILD_CC)" \
  23. CFLAGS="${BUILD_CFLAGS}" \
  24. CPPFLAGS="${BUILD_CPPFLAGS}" \
  25. LDFLAGS="${BUILD_LDFLAGS}" \
  26. blacklist-encode || die
  27. cat [DR]SA-* | ./blacklist-encode 6 > blacklist
  28. }
  29. src_install() {
  30. insinto /etc/ssh
  31. doins blacklist || die
  32. }