owncloud-client-2.3.1.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Synchronize files from ownCloud Server with your computer"
  6. HOMEPAGE="http://owncloud.org/"
  7. SRC_URI="http://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
  8. LICENSE="CC-BY-3.0 GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc dolphin nautilus samba +sftp test"
  12. COMMON_DEPEND=">=dev-db/sqlite-3.4:3
  13. dev-libs/qtkeychain[qt5]
  14. dev-qt/qtconcurrent:5
  15. dev-qt/qtcore:5
  16. dev-qt/qtdbus:5
  17. dev-qt/qtgui:5
  18. dev-qt/qtnetwork:5
  19. dev-qt/qtsql:5
  20. dev-qt/qtwebkit:5
  21. sys-fs/inotify-tools
  22. virtual/libiconv
  23. dolphin? (
  24. kde-frameworks/kcoreaddons:5
  25. kde-frameworks/kio:5
  26. )
  27. nautilus? ( dev-python/nautilus-python )
  28. samba? ( >=net-fs/samba-3.5 )
  29. sftp? ( >=net-libs/libssh-0.5 )
  30. "
  31. RDEPEND="${COMMON_DEPEND}
  32. !net-misc/ocsync
  33. !net-misc/nextcloud-client
  34. "
  35. DEPEND="${COMMON_DEPEND}
  36. dev-qt/linguist-tools:5
  37. doc? (
  38. dev-python/sphinx
  39. dev-texlive/texlive-latexextra
  40. virtual/latex-base
  41. )
  42. dolphin? ( kde-frameworks/extra-cmake-modules )
  43. test? (
  44. dev-util/cmocka
  45. dev-qt/qttest:5
  46. )
  47. "
  48. S=${WORKDIR}/${P/-}
  49. src_prepare() {
  50. # Keep tests in ${T}
  51. sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die "sed failed"
  52. if ! use nautilus; then
  53. pushd shell_integration > /dev/null || die
  54. cmake_comment_add_subdirectory nautilus
  55. popd > /dev/null || die
  56. fi
  57. default
  58. }
  59. src_configure() {
  60. local mycmakeargs=(
  61. -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
  62. -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
  63. -DWITH_ICONV=ON
  64. -DWITH_DOC=$(usex doc)
  65. -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
  66. -DBUILD_WITH_QT4=OFF
  67. -DCMAKE_DISABLE_FIND_PACKAGE_Libsmbclient=$(usex !samba)
  68. -DCMAKE_DISABLE_FIND_PACKAGE_LibSSH=$(usex !sftp)
  69. -DUNIT_TESTING=$(usex test)
  70. )
  71. cmake-utils_src_configure
  72. }
  73. pkg_postinst() {
  74. if ! use doc ; then
  75. elog "Documentation and man pages not installed"
  76. elog "Enable doc USE-flag to generate them"
  77. fi
  78. }