packETH-1.7.3.ebuild 560 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Packet generator tool for ethernet"
  6. HOMEPAGE="http://packeth.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/packeth/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. RDEPEND="
  12. dev-libs/glib:2
  13. x11-libs/gdk-pixbuf
  14. x11-libs/gtk+:2
  15. "
  16. DEPEND="
  17. virtual/pkgconfig
  18. ${RDEPEND}
  19. "
  20. DOCS=( AUTHORS CHANGELOG README TODO )
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${P}-libs-and-flags.patch
  23. eautoreconf
  24. }