pedro-1.6.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils
  5. DESCRIPTION="Pedro is a subscription/notification communications system"
  6. HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/PedroHome.html"
  7. SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/PedroFiles/${P}.tgz
  8. doc? ( mirror://gentoo/${PN}-manual-${PV}.tar.gz )"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86"
  12. IUSE="doc examples"
  13. RDEPEND="dev-libs/glib:2"
  14. DEPEND="${RDEPEND}"
  15. S="${WORKDIR}"/${P}
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${P}-portage.patch
  18. }
  19. src_install() {
  20. emake DESTDIR="${D}" install || die "emake install failed"
  21. dodoc AUTHORS README || die
  22. if use doc ; then
  23. dodoc "${WORKDIR}"/${PN}.pdf || die
  24. fi
  25. if use examples ; then
  26. insinto /usr/share/doc/${PF}/examples
  27. doins src/examples/*.{c,tcl} || die
  28. insinto /usr/share/doc/${PF}/examples/java_api
  29. doins src/java_api/*.java || die
  30. insinto /usr/share/doc/${PF}/examples/python_api
  31. doins src/python_api/*.py || die
  32. fi
  33. }