pipes-1.16.1.ebuild 649 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Very versatile TCP pipes"
  6. HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
  7. SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc s390 x86"
  11. src_prepare() {
  12. # Prevent the build system from looking for dependencies
  13. touch .depend || die
  14. }
  15. src_compile() {
  16. emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}"
  17. }
  18. src_install() {
  19. dobin plis
  20. dosym /usr/bin/plis /usr/bin/pcon
  21. dodoc Examples ChangeLog
  22. dohtml README.html
  23. }