portspoof-1.1.ebuild 588 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="return SYN+ACK for every port connection attempt"
  5. HOMEPAGE="http://portspoof.org/"
  6. LICENSE="GPL-2+"
  7. SLOT="0"
  8. IUSE=""
  9. DEPEND=""
  10. RDEPEND="${DEPEND}"
  11. if [[ ${PV} == "9999" ]] ; then
  12. inherit git-r3 autotools
  13. EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
  14. KEYWORDS=""
  15. else
  16. SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  17. KEYWORDS="~amd64 ~x86"
  18. fi
  19. src_prepare() {
  20. if [[ ${PV} == "9999" ]] ; then
  21. eautoreconf
  22. fi
  23. }