portspoof-1.3.ebuild 913 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="return SYN+ACK for every port connection attempt"
  5. HOMEPAGE="http://portspoof.org/"
  6. LICENSE="GPL-2+"
  7. SLOT="0"
  8. IUSE=""
  9. DEPEND=""
  10. RDEPEND="${DEPEND}"
  11. if [[ ${PV} == "9999" ]] ; then
  12. inherit git-r3 autotools
  13. EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
  14. KEYWORDS=""
  15. else
  16. SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  17. KEYWORDS="~amd64 ~x86"
  18. fi
  19. src_prepare() {
  20. if [[ ${PV} == "9999" ]] ; then
  21. eautoreconf
  22. fi
  23. sed -i \
  24. 's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
  25. system_files/init.d/portspoof.sh
  26. }
  27. src_install() {
  28. default_src_install
  29. newsbin system_files/init.d/portspoof.sh portspoof-runner
  30. }