pssh-2.3.1-r1.ebuild 770 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
  8. HOMEPAGE="https://code.google.com/p/parallel-ssh/"
  9. SRC_URI="https://parallel-ssh.googlecode.com/files/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
  13. IUSE=""
  14. RDEPEND="net-misc/openssh
  15. !net-misc/putty"
  16. DEPEND="${RDEPEND}
  17. dev-python/setuptools[${PYTHON_USEDEP}]"
  18. # Requires ssh access to run.
  19. RESTRICT="test"
  20. pkg_setup() {
  21. python-single-r1_pkg_setup
  22. }
  23. python_prepare_all() {
  24. sed -i -e "s|man/man1'|share/&|g" setup.py || die
  25. distutils-r1_python_prepare_all
  26. }