pycnb-0.0.4-r1.ebuild 581 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Access cnb.cz daily rates with the comfort of your command line"
  7. HOMEPAGE="https://github.com/yaccz/pycnb"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. DEPEND="dev-python/cement[${PYTHON_USEDEP}]
  13. dev-python/twisted-web
  14. dev-python/setuptools[${PYTHON_USEDEP}]"
  15. RDEPEND="${DEPEND}"
  16. src_unpack() {
  17. default
  18. chmod -R a+rX,u+w,g-w,o-w ${P} || die
  19. }