pyhoca-cli-0.5.0.2-r1.ebuild 632 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="X2Go command line client"
  7. HOMEPAGE="http://www.x2go.org"
  8. SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
  9. LICENSE="AGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
  14. >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
  15. RDEPEND="${DEPEND}"
  16. python_install() {
  17. distutils-r1_python_install
  18. python_doscript ${PN}
  19. }
  20. python_install_all() {
  21. distutils-r1_python_install_all
  22. doman man/man1/*
  23. }