pyhoca-gui-0.5.0.5.ebuild 809 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="X2Go graphical client applet"
  7. HOMEPAGE="http://www.x2go.org"
  8. SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
  9. LICENSE="AGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
  14. dev-python/pycups[${PYTHON_USEDEP}]
  15. dev-python/setproctitle[${PYTHON_USEDEP}]
  16. dev-python/wxpython[${PYTHON_USEDEP}]
  17. >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
  18. DEPEND="${DEPEND}
  19. dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
  20. python_install() {
  21. distutils-r1_python_install
  22. python_doscript ${PN}
  23. }
  24. python_install_all() {
  25. distutils-r1_python_install_all
  26. doman man/man1/*
  27. }