python-x2go-0.5.0.3.ebuild 591 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="X2Go client-side Python API"
  7. HOMEPAGE="http://www.x2go.org"
  8. SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
  9. LICENSE="AGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. # TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
  14. DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
  15. dev-python/paramiko[${PYTHON_USEDEP}]
  16. dev-python/python-xlib[${PYTHON_USEDEP}]
  17. net-misc/nx"
  18. RDEPEND="${DEPEND}"